한국어

tc_backup

아래 내용은 패킷트레이서(Packet Tracer) 프로그램으로 실습한 내용입니다.
라우터0과 라우터1에서 시리얼포트를 사용할 수 있도록 모듈을 장착하여 주어야 합니다.

R0(config)#inter fastEthernet 0/0
R0(config-if)#ip add 28.28.1.1 255.255.255.0
R0(config-if)#no shutdown
R0(config)#inter serial 0/0/0
R0(config-if)#ip add 28.28.12.1 255.255.255.0
R0(config-if)#bandwidth 64
R0(config-if)#clock rate 64000
R0(config-if)#no shutdown
R0(config-if)#

R0 라우터 설정하고 R1 라우터를 설정한다.
단, clock rate 를 주는 곳과 주지 않는 곳을 반드시 확인하여 구별하여라.
DCE인지 DTE인지 알고 있어야 라우터끼리 물리적인 연결이 된다.

R1(config)#interface Serial 0/0/0
R1(config-if)#ip add 28.28.12.2 255.255.255.0
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
R1(config)#interface FastEthernet 0/0
R1(config-if)#ip add 28.28.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface FastEthernet 0/1
R1(config-if)#ip add 28.28.3.1 255.255.255.0
R1(config-if)#no shutdown

그 다음에 show ip interface brief 하여
up up 상태인지 확인하여 보고 라우터끼리 핑이 가는지 확인하여 본다.
정상적으로 핑에 된다면 아래로 다음 단계로 넘어간다.

PC1과 PC2를 설정하기 위해
먼저 PC1을 더블클릭하여 보면 창이 뜨고 스크린샷과 동일한 화면을 볼 수 있다.


Config 화면에서 GLOBAL Settings 메뉴에서 Gateway를 28.28.1.1(연결된 라우터IP)로 설정한다
INTERFACE FastEthernet 메뉴에서 IP에는 28.28.1.2(부여받을IP)와 서브넷마스크를 적어준다.
PC2도 동일하게 설정하되 부여받을IP는 28.28.1.3으로 지정한다.
그 다음은 Server 세팅이다. Server 세팅도 PC 세팅과 동일하다.
Gateway를 라우터 아이피(Server0은 28.28.2.1, Server1은 28.28.3.1)로 지정하여 주고 인터페이스의 페스트이더넷부분에서 아이피와 서브넷마스크를 적어주면 된다
Server0은 28.28.2.2이고 서브넷은 255.255.255.0
Server1은 28.28.3.2, 서브넷은 255.255.255.0
기본적인 세팅은 이루어져서 전부 녹색불이 들어와 있을 것이다.
PC0에서 R0 라우터로 핑테스트 해보고 R0번에서 R1번으로 핑테스트 해보고 R1번에서 server로 핑테스트 해보길 바란다.
정상적으로 핑이 다 간다면 물리적 연결은 정상적으로 다 한것이다.
만일 핑이 안간다면 여기서 다시 확인하여 정상적으로 세팅해놓고 다음 단계로 진행한다.

그 다음은 다이나믹라우팅을 하여야 한다.
라우터 콘솔로 다시 가서
R0(config)#router rip
R0(config-router)#version 2
R0(config-router)#no auto-summary
R0(config-router)#net 28.0.0.0

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#net 28.0.0.0

show ip route 해서 제대로 라우팅이 됐는지 확인하고
핑 때려서 어디로든지 다 연결되는지 확인해본다
정상적으로 되면 다이나믹 라우팅도 정상적으로 하였다.
여기서는 RIPv2 로 하였으나
그 외 EIGRP나 OSPF로 하여도 무관함.

그 다음 중요한 ACL(Access List)을 하여야 한다.
하기 전에 먼저 주어진 문제와 패킷 트레이서를 보면서 어떤 그림인지 확인하여 본다

주어진 내용은
PC0에서 server0으로 http를 차단하고 그 외는 허용.
PC1은 외부로 ping 차단, 그 외는 다 허용.

해당 내용을 하기 위하여서는 Standard IP Access List로는 안된다. Extended IP Access List를 적용하여야 한다.

PC0에서 server0으로 http를 차단하기 위해서는
R0 라우터에서 ACL을 작성하여도 되지만 R1에서 작성하는게 더 옳바른 방법이다.
구별은 얼마나 효율적으로 ACL을 작성할수 있는지 판단하는 능력이다.
R1의 Fa0/0에서 나가는 것(out)을 막는 것이 가장 효율적이다.
http는 기본적으로 tcp 80번 포트를 사용한다(예외도 있음)

두번째로 PC1은 외부로의 ping 차단을 하여야 한다.
ping 은 icmp를 이용한다.
외부로의 차단을 막기 위하여는 R0 라우터의 Fa0/0번에 들어오는 것(in)을 차단하는 것이 옳바른 방법이다.
이제 어떻게 하여야하는지 알았기 때문에 실제로 차단하여 보자
http 먼저 차단하여 보자

R1 라우터에서
R1(config)#access-list 101 deny tcp 28.28.1.2 0.0.0.0 28.28.2.2 0.0.0.0 eq 80
R1(config)#access-list 101 permit ip any any
R1(config)#interface Fastethernet 0/0
R1(config-if)#ip access-group 101 out

정말로 PC0에서 http가 차단됐는지 확인하여 보자
PC0을 더블클릭하고 Desktop 메뉴로 가면 Web Browser 메뉴가 있다.
클릭하여 URL에 아이피를 입력한다. Server0의 아이피는 28.28.2.2가 된다.
Request Timeout 이 나오면 정상적으로 차단 된 것이다.
또 Server1로도 접속해보자. 28.28.3.2 로 접속하여 보면 정상적으로 접속이 될 것이다.
Server0만 http를 차단한 것이다.
여기서 문제.
Server1도 http를 차단하고자 한다면?
그럴 경우엔 Server1도 동일한 방법으로 차단하거나
아니면 R1에서 한번에 차단시켜도 된다.

두번째로 핑을 막아보자.
R0 라우터에서
R0(config)#access-list 101 deny icmp 28.28.1.3 0.0.0.0 any
R0(config)#access-list 101 permit ip any any
R0(config)#interface Fastethernet 0/0
R0(config-if)#ip access-group 101 in

PC1을 더블클릭한후 프롬프트를 눌러
ping을 날려보자. 핑이 안갈 것이다.단, PC0(28.28.1.2)로만 간다. 그 외에는 다 안갈 것이다.
그 이유는 스위치가 있기 때문이다. 스위치가 있기에 R0으로 가지 않고 스위치에서 바로 PC0으로 가기 때문이다.
이는 스위치는 브로드캐스트를 나눌수 없기 때문이다. 같은 브로드캐스트에 포함이 되기에 가능한 것이다.
그리고 아래는 패킷트레이서로 작성한 내용을 저장한 것이다.
ACL_ripv2.pkt
List of Articles
번호 제목 글쓴이 날짜 조회 수sort
20 RCE Windows Anti-Debug Reference [7] file 엔신 2009-06-10 33612
19 Windows VMware VMwareDnD 폴더 엔신 2009-03-07 33881
18 CCNA 서브넷팅 : 가장효율적으로 IP를 할당할수 있는 방법!!(VLSM) 엔신 2008-05-12 33977
17 Linux configure: error: No curses/termcap library found 엔신 2008-02-24 35374
16 Security SSH Port Forwarding(SSH Tunneling) [2] file 엔신 2009-05-29 36553
15 CCNA Frame-relay(프레임릴레이) multipoint 방식 풀메쉬 토플로지 구현 file 엔신 2008-06-09 36780
14 RCE [MUP] UPX & Stolen Bytes [2] file 엔신 2009-02-17 37480
13 Windows 64비트 운영체제에서 아크로뱃 설치시 adobepdf.dll 파일이 없다고 할 때 [5] file 엔신 2007-07-25 38417
12 WideCap을 통한 Proxy 이용 file 엔신 2013-04-20 39810
11 Linux 삭제 파일 복구하기 debugfs 엔신 2008-02-23 41812
» CCNA ACL(Access List) 설정하기 file 엔신 2008-05-28 42588
9 Programming COleDateTime 클래스 엔신 2009-11-23 43263
8 Security base64 code 표 file 엔신 2009-01-20 44582
7 freeware hex editor 엔신 2013-01-22 51204
6 [VBA] 파워포인트 그림 리사이즈, 위치 고정 엔신 2013-02-21 51700
5 [APC3.0] AhnLab Policy Center 3.0 관련 모듈 목록 엔신 2013-03-21 53313
4 CCNA 14.[EIGRP] file 엔신 2008-05-26 56001
3 DBMS MySQL 설치/사용시 나는 에러 유형별 대처방법 엔신 2008-02-24 63588
2 Security Nessus 설치, 사용법 file 엔신 2008-12-11 93606
1 [VBA] 엑셀 시트명 가져오기 엔신 2013-01-22 132705